Intermittent service affecting LL22 postcode area

Incident Report for Airband

Update

Our engineers are still diagnosing the issue that is causing a disruption to your service. Please be assured that getting all customers back online is our number one focus. Once we have identified the issue we will update all impacted customers on resolution time.
Posted Jun 14, 2026 - 18:47 BST

Update

We are continuing to investigate this issue.
Posted Jun 14, 2026 - 17:12 BST

Investigating

We are currently investigating this issue.
Posted Jun 14, 2026 - 15:18 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 14, 2026 - 13:00 BST

Investigating

We are currently investigating this issue.
Posted Jun 14, 2026 - 12:15 BST
This incident affects: Airband Wireless Networks (Towyn).