Loss of service affecting TF9 postcode area.
Incident Report for Airband
Resolved
This incident has been resolved.
Posted Apr 25, 2024 - 14:27 BST
Investigating
We are currently investigating this issue.
Posted Apr 24, 2024 - 14:14 BST
This incident affected: Airband Wireless Networks (Shropshire).