Intermittent service affecting PL16, PL19, EX20 postcode areas

Incident Report for Airband

Resolved

This incident has been resolved.
Posted May 31, 2026 - 09:22 BST

Identified

Our engineers have now diagnosed the problem with your connection and are now working on fixing the issue. At this moment we do not have a resolution time, we will let you know when this changes. Thank you for your ongoing patience and understanding.
Posted May 30, 2026 - 15:32 BST

Investigating

We are currently investigating this issue.
Posted May 30, 2026 - 15:11 BST
This incident affected: Airband Wireless Networks (Devon).