Loss of service affecting DY13, DY14, TA24, WR2, WR3, WR6, WR7, WR9, WR13, WR14 and WR15 post code areas.
Incident Report for Airband
Resolved
This incident has been resolved.
Posted May 06, 2024 - 13:00 BST
Investigating
We are currently investigating this issue.
Posted May 05, 2024 - 17:49 BST
This incident affected: Airband Wireless Networks (Worcestershire).